WorldWideScripts.net Delivering the best Add-Ons in more than 37 languages.

中文(简体), English, हिन्दी/हिंदी, Español/Castellano, العربية, Русский язык, Français, 中文 (台灣), বাংলা, Bahasa Indonesia, اردو, Português, Deutsch, Bahasa Melayu (بهاس ملايو‎), 日本語 (にほんご), فارسی, Italiano, తెలుగు, Türkçe, ગુજરાતી, Język polski/polszczyzna, Tiếng Việt, ಕನ್ನಡ, Українська мова, ไทย
PHP Scripts / Miscellaneous

PHP Version Finder

— Add-On till WorldWideScripts.net

Prenumerera på vårt foder för att hålla dig uppdaterad!

Nytt! Följ oss som du vill ha det!


PHP Version Finder - CodeCanyon Item for Sale

Ads

Ad: Bluehost hosting

Följ mig på Twitter Följ mig på G + Följ mig på CodeCanyon Live Demo

Demo - Non Database (handikappad)
Demo - Database (handikappad)
De demos är förlamad! Vi har oordning den sanna versionen av varje funktion och förlängning.

PHP Version Finder - uppdaterad till v 1.0.3c 2010/12/09

Hitta vilken version av PHP ditt manus kräver. När vi frågade vilken version av PHP krävs för att köra våra manus vi inte har ett definitivt svar. Vi skapade det här skriptet för att bestämma PHP version, och sedan tog vi det till en annan nivå genom att söka föråldrade funktioner. Men vi slutade inte bara på det. Vi ingår PHP Extensions och språkkonstruktioner. Vi nästan kallade det bra på det, men då vi undrade... hur många gånger vi använt dessa funktioner. Överdriven användning av samma funktion kan förnedrande på prestation. Övervakning hur många gånger en funktion används kan hjälpa till att avgöra om det går att skapa en "användarskapat funktion" för att minska kod och öka prestanda.

Upptäckt

PHP Version Finder spår: 3044 PHP funktioner, 2260 PHP extensions, 23 språkkonstruktioner, 19 alternativa förslag, 7 Tips / Tricks / Notes. (Plus 69 Experimentell, 20 Deprecated, 47 "svn" funktioner)
Koden behöver inte vara fullständig eller funktion. Det behöver inte ens vettigt. Så länge det är mellan <? Php och?> Kommer det att utvärderas. Handikappad Demo - Demon har lamslagit att hindra folk från att använda den i stället för att köpa den.

Sluta gissa!

Sanningen skall fram - de flesta utvecklare "ball-park" vilken version av PHP kräver att påminna några "nyckel" funktioner som de används. Med PHP Version Finder kan du säkert vet vad PHP-version är faktiskt krävs!
Inte gissa! - Kör PHP Version Finder på ditt manus att veta säkert vad verions av PHP krävs för att driva ditt manus!

fasats Detektion

PHP Version Finder låter dig veta om några funktioner som du använt föråldrat.
Deprecated Detection - Kontrollera dina skript för föråldrade funktioner

två versioner

PHP Version Finder kräver inte en databas. Men för dem av er som hellre skulle använda en databas, gör skriptet innehålla en databasversion.
Optionhal Databas - PHP version finder inte kräver en databas, dock en alternativ version levereras för dem som vill använda en databas.
Varför två versioner?
Det hela handlar om siffror. Om det finns massor av PHP funktioner, är den icke databasversion snabbare. Om det bara finns ett fåtal funktioner, är den databasversion snabbare. Hur mycket snabbare? Tja, det mäts i mikrosekunder. Så inte riktigt märkbar. Efter att vi gjort databasversion beslutade vi att det var inte värt ansträngningen som dess prestanda var inte märkbar annorlunda. Vi bestämde oss för att ta det eftersom det var redan byggt - en fribiljett om du vill.

Installation

Installationen är enkel. Ladda katalogen, redigera två inställningar och du är klar.
Installion - Ladda en katalog till din server, redigera en konfigurationsfil och din redo att gå!

ingångar

Du kan ladda upp en fil från din dator, skanna en fil eller hela katalogen på servern, eller klistra in koden i en låda för bearbetning.
Flera ingångar - Du kan ladda upp en fil, skanna en katalog eller kontrollera ett block av kod.

alternativa förslag

Om PHP Version Finder hittar funktioner som föråldrade, kommer det att ge dig alternativa förslag som kan ersätta den föråldrade funktionen.
Alternativa förslag - Du kan göra ditt manus Till exempel:
om du använder file_put_contents (som kräver PHP 5), kommer PHP Version Finder låta dig veta att du kan använda fwrite stället som skulle kunna sänka den version ner till PHP 4. Inte bara det, men det finns en anteckning bifogas file_put_contents som visar koden för att använda för att göra file_put_contents bakåtkompatibel.

Köp PHP Version Finder NU!

Gör livet enkelt! Hitta nedgraderade funktioner, få bakåtkompatibla förslag och veta vilken version av PHP krävs för att köra skript
Köp nu - göra livet enkelt, hitta föråldrade funktioner, få bakåt kompatibla förslag och veta vilken version av PHP krävs för att köra skript.

Aktuella funktioner (v 1.0.0) - 12/1/2010

  • valfritt Databas
  • fasats Detektion
  • Filuppladdning Processing
  • katalog Processing
  • Klistras kod Processing
  • Komplettera automatiskt
  • syntax Highlighter
  • 3044 PHP funktioner
  • 2260 PHP Extensions
  • 23 språkkonstruktioner
  • 19 alternativa förslag
  • 7 Tips / Tricks / Noter
  • Plus 69 Experimentella Funktioner
  • Plus 20 Borttagen funktioner
  • Plus 47 "svn" / okända funktioner

Uppdatering v 1.0.1 2010/12/03

  • Fasta Notice varningar
  • Fasta "odefinierade variabler" Fel
  • Fasta stavfel
  • Uppdaterad Hjälpfil för att spegla förändringar
  • Added Licensing Förklaring
  • Rensas upp "Rapport File"

Uppdatering v 1.0.2 2010/12/04

  • Fasta Notice varningar
  • Fasta "odefinierade variabler" Fel
  • Uppdaterad Hjälpfil för att spegla förändringar

Uppdatering v 1.0.3c 2010/12/09

  • Saneras kod
  • Rewrote hur statistik är stämde.
  • Skrev "Rapport File"

Hämta
Andra komponenter i denna kategoriAlla komponenter i denna författare
KommentarerVanliga frågor och svar

Egenskaper

Skapad:
3 December 10

Senaste uppdateringen:
10 December 10

Hög upplösning:
Nej

kompatibla Webbläsare:
IE7, IE8, Safari, Opera

filer ingår:
JavaScript JS, HTML, CSS, PHP, SQL

Mjukvaru-version:
PHP 4.x, PHP 5.x, PHP 5,0-5,2, PHP 5.3, MySQL 5.x

Nyckelord

e-handel, e-handel, Alla objekt, fö, rå, ldrat varning, php version, syntaxmarkering